Analytics Database Issues

Incident Report for Bitmovin Inc

Resolved

This incident has been fully resolved.
All services have operational, and all buffered data has been successfully backfilled as of 06:57 UTC. No data was lost during the incident.
Posted Jul 15, 2025 - 07:59 UTC

Monitoring

We have resolved the underlying issues affecting the Analytics backend database. All services have fully recovered, and query error rates have returned to normal levels.

We are now actively backfilling the buffered data to ensure all historical events are written and available in the system. No data has been lost.

We will continue to monitor the system closely and provide a final update once the backfill is fully complete.
Posted Jul 15, 2025 - 06:47 UTC

Investigating

We are currently investigating elevated query error rates and backend insert failures affecting our main Analytics database.
While queries may intermittently fail and analytics dashboards may show incomplete or delayed data, no data is being lost — all incoming events that cannot currently be written are being safely buffered.

Our engineering team is actively working to identify the root cause and restore full functionality.
We will continue to provide updates as the situation evolves.
Posted Jul 15, 2025 - 06:40 UTC
This incident affected: Analytics Service (Analytics Ingress, Query Service, Export Service).